cancel
Showing results for 
Search instead for 
Did you mean: 

SoapUI Pro 3.3.2 and Swagger 3.0.1 OAS 3.0.1

SOLVED
Highlighted
Frequent Visitor

SoapUI Pro 3.3.2 and Swagger 3.0.1 OAS 3.0.1

Hi,

we have developed a Swaggerhub in version 3.0.1 with authentication NTLM/ https (certificate is valid).

When I try to connect to swagger:

1.New project

2.Type = Swagger/ OpenAPI definition

3.URL = xxx.xxx.xxx/swagger/v1/swagger.json

Prompt appears, enter valid credentials username/ password and domain. Hit enter.

Same prompt appears…. 

I can access the endpoint directly but not through the swagger definition that has openapi: "3.0.1".

I can create a new “rest step“ and with url https://xxxx.xx.xx/swagger/v1/swagger.json and get a response.

But then I miss the whole idea of getting the Swagger definitions.

What I can read here: https://community.smartbear.com/t5/SoapUI-Pro/Openapi-3-0-1-in-ReadyAPI-3-0-0/td-p/196697

is that it’s not supported.

So could you tell me whats is going on here?

 

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Manager

Re: SoapUI Pro 3.3.2 and Swagger 3.0.1 OAS 3.0.1


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

1 REPLY 1
Highlighted
Community Manager

Re: SoapUI Pro 3.3.2 and Swagger 3.0.1 OAS 3.0.1


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors