cancel
Showing results for 
Search instead for 
Did you mean: 

SOAPui 5.3.0 and API Ready 2.7.0 issues known?

Highlighted
New Contributor

SOAPui 5.3.0 and API Ready 2.7.0 issues known?

we are working with 2 versions of SOAPui.

Open source 5.3.0 and paid Rady API 2.7.0

Are issues known for this?

I notice that I loose information in projects of the free version. Requests can not be opened anymore.

And that in REady API the rest service information disappears when creating a testsuite.

5 REPLIES 5
Highlighted
Super Contributor

Re: SOAPui 5.3.0 and API Ready 2.7.0 issues known?

While not a direct answer to your question, the latest release is 2.8.2, thus reviewing the list of bugs fixed:

 

https://support.smartbear.com/readyapi/docs/general-info/version-history/bugs-fixed-in-ver-2-8.html

 

should give you an idea of potential problems with version 2.7

Highlighted
New Contributor

Re: SOAPui 5.3.0 and API Ready 2.7.0 issues known?

Thanks

It does not give me the clue I was looking for - maybe because I am not so technical.

 

Is there anyone who faced the issue of loosing the details of all the requests (you can not open the requests anymore)?

Highlighted
Community Hero

Re: SOAPui 5.3.0 and API Ready 2.7.0 issues known?

Hi @msiteur,

If you're talking about having created a project in ReadyAPI! and then importing that project into open source SoapUI, I had similar problems about 3 months ago.

About 3 months ago i had to try and get my ReadyAPI! project working in open source SoapUI (i think it was v5.5.0, rather than v5.3.0) and i found a number of problems that i had to recreate some of my tests and test steps that were originally created in ReadyAPI!, as well as changing/adding steps to get it to work as required in SoapUI.

I'd suggest we'd need to know a lot more detail about the requests that are "disappearing" to even come close to trying to help out with your issues. What type of requests are you talking about? Payloads? Methods? Etc.

Are you using parameterisation? I noticed i was getting a lot of problems when my requests used parameterization....do your requests use a lot of parameterisation?

Have you made sure you're not using any of the Pro (paid for) functionality that's available in ReadyAPI! that isn't in the open source SoapUI?

When importing a ReadyAPI! project into SoapUI, you do get a warning dialogue that there might be problems executing the project in SoapUI, so it isn't exactly advisable.

If you can provide more information as to your issues (exact details of the problems) i can see if i can reproduce and perhaps work out a way around the problem. If this doesn't work i think you have 2 choices:

1. Upgrade the freeware SoapUI to the latest (i think it's about v5.5.3) and hope the changes since your version (v5.3.0) have fixed the problems causing your issue or

2. Do what someone suggested to me when i had problems....recreate your project from scratch in opensource SoapUI, rather than creating in ReadyAPI! and importing into SoapUI.

Thats all i got i'm afraid!

Ta

Rich

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
New Contributor

Re: SOAPui 5.3.0 and API Ready 2.7.0 issues known?

Disappearing request - I mean with that that the content of your requests (definitions) and the test steps can not be opened. The content seems to have lost.

The file size was a lot smaller.

I will try to recreate my issue and add some screenshots. Could take a while, because I have other things to do.

Installing the latest versions might help out. Not sure though.

Highlighted
Community Hero

Re: SOAPui 5.3.0 and API Ready 2.7.0 issues known?

Hi @msiteur 

 

I'd definitely update - you don't know it won't make an improvement - but that's the least you can do!

 

don't forget to add the screenshots etc. when you have time,

 

nice one,

 

rich

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors