Showing results for 
Search instead for 
Did you mean: 

Refactoring Function Doesn't Do ANYTHING! ReadyAPI! v2.3.0

Community Hero

Refactoring Function Doesn't Do ANYTHING! ReadyAPI! v2.3.0



I was curious about the refactoring function (due to someone else's post) and I tried it following the instructions - but nothing happened after selecting the function.



Tried the following:


Select the 'Rest Service' (immediately below the project in the 'Projects' screen), and hitting the 'Refactoring' button in the menu.


Select the 'Rest Service', select 'API' >> 'Refactor Definition' via the menu.


I'm running ReadyAPI! v2.3.0 - has anyone else had this problem?


I should highlight that nothing is reported within teh ReadyAPI! log when I attempt to launch the 'Refactoring' functionality.


I've also had intermittent access to the 'Preferences' functionality too - occasionally I select to launch the 'Preferences' and nothing happens. change. change.  Some time passes by and it works again!





if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
New Here?
Join us and watch the welcome video:
Top Kudoed Authors