cancel
Showing results for 
Search instead for 
Did you mean: 

ReadyApi 3.1.0 and Maven

SOLVED
Cekay
Contributor

ReadyApi 3.1.0 and Maven

Huhu wonderful people 😃

 

I updated my SoapUI to the newest version and try to run it via Maven. Unfortunately I get this error message:

 

[ERROR] Failed to execute goal com.smartbear:ready-api-maven-plugin:3.1.0:test (default) on project flexibill-soapui-tests: Execution default of goal com.smartbear:ready-api-maven-plugin:3.1.0:test failed: Unable to load the mojo 'test' in the plugin 'com.smartbear:ready-api-maven-plugin:3.1.0' due to an API incompatibility: org.codehaus.plexus.component.repository.exception.ComponentLookupException: com/eviware/soapui/maven2/TestMojo has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0

 

Has someone an idea how to fix this?

 

Thanks and Cheers

Cekay

2 ACCEPTED SOLUTIONS

Accepted Solutions
sonya_m
Community Manager

Re: ReadyApi 3.1.0 and Maven

Thank you for help nmrao!

 

Hi @Cekay , I would recommend, that you contact the support team since this might require additional investigation.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

Cekay
Contributor

Re: ReadyApi 3.1.0 and Maven

Support Team was not able to help me back than. But now I have the answer:

https://community.smartbear.com/t5/SoapUI-Pro/Maven-Java-8-and-the-newest-SoapUi-Version/m-p/206678#...

 

We have to use Java12

View solution in original post

4 REPLIES 4
nmrao
Community Hero

Re: ReadyApi 3.1.0 and Maven

Do you have multiple JDK / JRE installed on you machine?
Aren't you using the jre provided by the tool?


Regards,
Rao.
Cekay
Contributor

Re: ReadyApi 3.1.0 and Maven

I am not sure that I understand your reply.

 

I have installed: Java and Java SE Development Kit

i do not have a problem with 3.0.0 and Maven why should 3.1.0 have an issue with it.

(Sorry I know nothing about those things ^^ I was told to install it so I can work with our Selenium tests)

sonya_m
Community Manager

Re: ReadyApi 3.1.0 and Maven

Thank you for help nmrao!

 

Hi @Cekay , I would recommend, that you contact the support team since this might require additional investigation.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

Cekay
Contributor

Re: ReadyApi 3.1.0 and Maven

Support Team was not able to help me back than. But now I have the answer:

https://community.smartbear.com/t5/SoapUI-Pro/Maven-Java-8-and-the-newest-SoapUi-Version/m-p/206678#...

 

We have to use Java12

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors