cancel
Showing results for 
Search instead for 
Did you mean: 

ReadyAPI header exists assertion failures

Highlighted
Contributor

ReadyAPI header exists assertion failures

Hey all,

Noticed something a little strange with the ReadyAPI "Header Exists" assertion.

Having a specific header checked to exist seems to be giving me mixed results between test run.

 

We have a data driven test and need to validate specific header information is returned in the header response.  Therefore, we are using the "Header Exists" assertion to ensure that information is returned in the header response.

 

The test will fail on one (or more) of the "Header Exists" assertions, yet when I view that response in Splunk, I see the expected response header information of that assertion which failed in the Splunk log, thus it should not have failed.
Executing the same test again, the same request might successfully assert the previously failed header exists assertions, yet fail on one (or more) of those "Header Exists" assertions for a different request which passed all header exists assertions in the previous test. Once again, checking the Splunk log for those which failed, shows the header information was in the header response for that request.

 

Has anyone else had this issue or seen something similar for the "Header Exists" assertion during test execution?

Thanks in advance !

Stu

4 REPLIES 4
Community Hero

Re: ReadyAPI header exists assertion failures

Hey @sdeevers

Can you provide a bit more about your issue?
What sort of executable request is it? REST or SOAP or HTTP?
What sort of header are you checking for....is it a typical environmental one or is it a custom functional parameter instead?
Ive never used Splunk so cant comment on that, but are you saying if you check the RAW details of the response you can see the relevant header present, but the Header Exists assertion is intermittently failing despite the fact the header is actually present?

Cheers,

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Highlighted
Contributor

Re: ReadyAPI header exists assertion failures

Rich,

This is a REST request where we are checking the header response. In the RAW response you will not get the specific header information in the response, yet run that same request again and the information to be asserted will be present. Using different information in the same REST request (the test being data driven), I may or may not get the header information to be evaluated. In each of the scenarios, the response is successful.

Highlighted
Community Manager

Re: ReadyAPI header exists assertion failures

Hi @sdeevers,

Which ReadyAPI version are you using? The latest product version is 3.5 - could you please check if you see the same behavior in this version? If you do, please submit a ticket to our ReadyAPI Support Team.

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted
Contributor

Re: ReadyAPI header exists assertion failures

Currently using the 3.4.5 release.
After further in-depth investigation of our request, the issue is not with the header exists assertion, but the assertion failure helped us immensely identify where our problem was.
Stu

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors