cancel
Showing results for 
Search instead for 
Did you mean: 

ReadyAPI TestSuite not opening (XML Error)

SOLVED
anagpal
Occasional Contributor

ReadyAPI TestSuite not opening (XML Error)

Hi, I created TestSuite in ReadyAPI, it was working fine till yesterday, Todat when i opened the tool, my test suite was grayed out and i am not able to open it. I tried to open the TestSuite XML it gives error: error on line 39605 at column 36: Extra content at the end of the document. But nothing seems wrong there. Yesterday i just added new test cases and today it stopped working. There are approx 40k lines in XML, as i haven't much experience in XML so i am not able to fix it. And now all my testing activities stopped as XML not opening. Please provide some suggestion how i can fix the XML.
1 ACCEPTED SOLUTION

Accepted Solutions
TanyaYatskovska
Community Manager

Re: ReadyAPI TestSuite not opening (XML Error)

Hi anagpal,

 

Try to import your project to ReadyAPI. For this, open the tool, select File > Import Project and specify the xml file. You can find more information in our documentation:

https://support.smartbear.com/readyapi/docs/projects/import.html

 

If this doesn't help, please submit a support case to our Customer Care team and attach the problematic file. You can contact them here: 

https://support.smartbear.com/message/?prod=ReadyAPI

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

3 REPLIES 3
TanyaYatskovska
Community Manager

Re: ReadyAPI TestSuite not opening (XML Error)

Hi anagpal,

 

Try to import your project to ReadyAPI. For this, open the tool, select File > Import Project and specify the xml file. You can find more information in our documentation:

https://support.smartbear.com/readyapi/docs/projects/import.html

 

If this doesn't help, please submit a support case to our Customer Care team and attach the problematic file. You can contact them here: 

https://support.smartbear.com/message/?prod=ReadyAPI

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

richie
Community Hero

Re: ReadyAPI TestSuite not opening (XML Error)

Hi @anagpal

 

just a follow up to what Tanya stated.  a similar thing happens quite often for me.  Essentially it sounds like what I get.  Essentially the project file is saved in .xml.  However, if the file isn't wellformed xml (including not wellformed relative to the specified default xml char encoding of UTF-8 - this will result in the file not being able to be opened.

 

If you try and open the project.xml file in something like XMLSpy (that has an XML parser) you will notice certain characters have been substituted because the file has become corrupt.

 

To fix this what I normally do is open the file in XMLSpy so I have an idea where the corruption is.  Then I close and reopen the file in something that doesnt include an XML parser like notepad++ and then I edit the file making it wellformed again.

 

project.xml file corruption has happened a lot for me - so Im quite used to fixing it when this happens.

 

cheers

 

richie

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
anagpal
Occasional Contributor

Re: ReadyAPI TestSuite not opening (XML Error)

thanks Richie 🙂

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors