Ask a Question

ReadyAPI 2.2 Failed to initialize the connection that uses the [com.ibm.db2.jcc.DB2Driver] driver.

SOLVED
jenniferxu99
Regular Visitor

ReadyAPI 2.2 Failed to initialize the connection that uses the [com.ibm.db2.jcc.DB2Driver] driver.

Hi ,

I try to create ReadyAPI JDBC connection with DB2 database,  I got this error message:

Failed to initialize the connection that uses the [com.ibm.db2.jcc.DB2Driver] driver. Connection string: [jdbc:db2://<Servername>:<portnumber>/<databasename>:user=<username>;password=#####;].

 

I put the db2jcc-4.14.113.jar file in ..\SmartBear\SoapUI-5.4.0\lib and  ...\SmartBear\SoapUI-5.4.0\bin\ext

 

Thanks you in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
richie
Community Hero

Re: ReadyAPI 2.2 Failed to initialize the connection that uses the [com.ibm.db2.jcc.DB2Driver] drive

Hey @jenniferxu99 

 

Apologies - I've only just seen this post - I dont know if you got any further - but DB2 config is fiddly - there's some extra stuff you need to be aware of

 

1.  which operating system is the DB2 running on - z/OS? Linux? etc. (it makes a difference - you might've noticed some of the SQL commands you use are different if you've used DB2 before (e.g. LTRIM etc.) - your SQL is differnet on different operating systems - and the db connection config is the same.  so you need to determine what operating system is supporting your DB and then speak to a DBA (I'll come back to this in a little while)

 

2.  You need to determine what version of Java your DB2 instance supports.  You need to install this version on the machine running ReadyAPI! (ensuring you install the right version (e.g. JRE/JDK v8.0) as well as whether it's x86 or 64bit.  If your ReadyAPI! is installed in Program Files directory you're running 64bit, so you need to download and install 64bit JRE and vice versa.  Make sure (I'm assuming Windows) that your 'Path' envnironment variable is updated wiht your Java install

 

3.  you need to then download the correct driver .jar files for your DB2 version - note - I cann't remember but it's VERY likely this will be operating system dependent.

 

4.  Speak to your DBA - you have specified the JDBC connection string in your post - there are 2 DB2 default JDBC connection strings installed by default with ReadyAPI! - these may work - they may not.  Whether they work or not is dependent on the DB2 setup.  Speak to a DBA about obtaining the correct details for the DB2 setup you have there - there may be additional parameters that are NOT included in the default JDBC connection strings.  If this is the case the default ones wont work -  you'll have to create a new DB2 connection string in the Preferences  >> JDBC Drivers.

 

There might be a bit of tweaking - but those are essentially the steps I used to connect my SoapUI instance to to DB2.

 

hit me back if you have any further queries!

 

Cheers,

 

rich

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

2 REPLIES 2
richie
Community Hero

Re: ReadyAPI 2.2 Failed to initialize the connection that uses the [com.ibm.db2.jcc.DB2Driver] drive

Hey @jenniferxu99 

 

Apologies - I've only just seen this post - I dont know if you got any further - but DB2 config is fiddly - there's some extra stuff you need to be aware of

 

1.  which operating system is the DB2 running on - z/OS? Linux? etc. (it makes a difference - you might've noticed some of the SQL commands you use are different if you've used DB2 before (e.g. LTRIM etc.) - your SQL is differnet on different operating systems - and the db connection config is the same.  so you need to determine what operating system is supporting your DB and then speak to a DBA (I'll come back to this in a little while)

 

2.  You need to determine what version of Java your DB2 instance supports.  You need to install this version on the machine running ReadyAPI! (ensuring you install the right version (e.g. JRE/JDK v8.0) as well as whether it's x86 or 64bit.  If your ReadyAPI! is installed in Program Files directory you're running 64bit, so you need to download and install 64bit JRE and vice versa.  Make sure (I'm assuming Windows) that your 'Path' envnironment variable is updated wiht your Java install

 

3.  you need to then download the correct driver .jar files for your DB2 version - note - I cann't remember but it's VERY likely this will be operating system dependent.

 

4.  Speak to your DBA - you have specified the JDBC connection string in your post - there are 2 DB2 default JDBC connection strings installed by default with ReadyAPI! - these may work - they may not.  Whether they work or not is dependent on the DB2 setup.  Speak to a DBA about obtaining the correct details for the DB2 setup you have there - there may be additional parameters that are NOT included in the default JDBC connection strings.  If this is the case the default ones wont work -  you'll have to create a new DB2 connection string in the Preferences  >> JDBC Drivers.

 

There might be a bit of tweaking - but those are essentially the steps I used to connect my SoapUI instance to to DB2.

 

hit me back if you have any further queries!

 

Cheers,

 

rich

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

View solution in original post

Olga_T
Moderator

Re: ReadyAPI 2.2 Failed to initialize the connection that uses the [com.ibm.db2.jcc.DB2Driver] drive

Great recommendations, @richie, thank you!

 

@jenniferxu99, was this information helpful? We are looking forward to hearing from you.


Olga Terentieva
SmartBear Assistant Community Manager

cancel
Showing results for 
Search instead for 
Did you mean: