cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with remote repo URL

SOLVED
nuv7
Occasional Contributor

Problem with remote repo URL

Hello,

 

Does anyone has problem with smartbear integrated with Azure?

 

I am using Azure DevOps.  Created a repo from Azure.  Converted the API project to a composite project.  I am able to connect to the user account from the git console.  My problem is when I try to push the project to the remote repo, I am getting error with connecting to the remote repository provided.  The error message is terrible and not enough information for me to troubleshoot.  Please help.

 

nuv7_0-1611850149735.png

 

nuv7_1-1611850207853.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Problem with remote repo URL

Hello! I tested this out and was unable to use a username/password combination to connect to an Azure repository like I would with Github or Bitbucket.

 

Instead, using a GIT profile (not linked to a specific provider) in ReadyAPI that held my username & an Azure PAT I was able to drop in the remote URL as you have shown and successfully push to the remote Azure repository.

 

View solution in original post

2 REPLIES 2

Re: Problem with remote repo URL

Hello! I tested this out and was unable to use a username/password combination to connect to an Azure repository like I would with Github or Bitbucket.

 

Instead, using a GIT profile (not linked to a specific provider) in ReadyAPI that held my username & an Azure PAT I was able to drop in the remote URL as you have shown and successfully push to the remote Azure repository.

 

View solution in original post

nuv7
Occasional Contributor

Re: Problem with remote repo URL

It works.  Thank you so much for your time and assistance.

 

Here are the steps that I do based on your instructions:

It generate the git credential from my Azure project.

Copy the token to the clipboard.

Enter the same user name and password token into the git integration in readyAPI.

Go to my repo and select clone.

Select SSH and select clone.

Copy the URL into the clipboard.

Test the connection in readyAPI and past the URL from the clipboard to the URL location.  

 

It works.  Thanks you.

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors