cancel
Showing results for 
Search instead for 
Did you mean: 

On launching TestRunner in SOAP UI Pro, the previous testdata is getting executed.

sandy55432
Occasional Contributor

On launching TestRunner in SOAP UI Pro, the previous testdata is getting executed.

Launched test runner at Testcase level but it is executing for old set of testdata always, My testdata sheet is updated with new data but it executes for old values.

 

Please let me know , if you have come across such issue.

 

6 REPLIES 6
richie
Community Hero

Re: On launching TestRunner in SOAP UI Pro, the previous testdata is getting executed.

Hi @sandy55432,

That's weird, cos readyapi!/soapui doesn't cache data...only .wsdls and properties according to the help.

You say running via testrunner is picking up the old testdata not the new datasheet. What happens when you execute without testrunner?
Cheers

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
sandy55432
Occasional Contributor

Re: On launching TestRunner in SOAP UI Pro, the previous testdata is getting executed.

Without testrunner, it does take the new testdata and executes it. When launching as Testrunner not sure from were it is fetching the values[old test data].

richie
Community Hero

Re: On launching TestRunner in SOAP UI Pro, the previous testdata is getting executed.

Hi @sandy55432,

I want to try and reproduce this.

Can you confirm the version you're running and the form you testdata takes....i.e. are you using a datasource file? or directory? type etc.

Cheers

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
sandy55432
Occasional Contributor

Re: On launching TestRunner in SOAP UI Pro, the previous testdata is getting executed.

My TestSuite has JBDC calls from various SQL database and am validating the data from each of the database and validating against the column values.

richie
Community Hero

Re: On launching TestRunner in SOAP UI Pro, the previous testdata is getting executed.

Hi @sandy55432 

 

you state "My TestSuite has JBDC calls from various SQL database and am validating the data from each of the database and validating against the column values.", but If we're gonna try and reproduce to help were gonna need more info.

 

What version of ReadyAPI! are you running?

 

you mention JDBC to source data - are you using Datasource DataConnection type? Datasource JDBC type?  JDBC step?  you mention validating the returned relational attribute values - how are you validating these?

 

As I said before - ReadyAPI! doesn't include the facility to cache data - there must be something else going on somewhere - but without further info it's unlikely anyone is gonna be able to help - can you provide screenshots of your test hierarchy, your step config, etc.?

 

Cheers,

 

rich

 

if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Olga_T
Moderator

Re: On launching TestRunner in SOAP UI Pro, the previous testdata is getting executed.

Hi all,

 

@richie, thank you for your assistance.

 

@sandy55432, what stage are you on now? Do you have any updates?


Olga Terentieva
SmartBear Assistant Community Manager

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors