cancel
Showing results for 
Search instead for 
Did you mean: 

OAuth get token can't open page

son-huynh-zd
Occasional Visitor

OAuth get token can't open page

Hello,

 

I am trying out SoapUI NG for the first time. When I try to add an OAuth authorization and get the token, the browser opens up with a "Unfortunately, we can't open this page!" message. Is there anyway around this? The URL works fine in a Chrome browser. I've also verified all other information is correct, the only thing I don't have specified is the scope.

 

Has anyone else had this problem?

 

Thanks!

7 REPLIES 7
Outlaw
New Contributor

Re: OAuth get token can't open page

Yeah same here, i am assuming that i am doing something wrong but it was good to finally realize that i am not alone.  if you figured this out already let me know.

rlong98
Contributor

Re: OAuth get token can't open page

I have this problem now...  I'll report back if I find out why.

 

I have 3 environments, one is working fine...

I notice that in my Salesforce TEST env - there is two Auth. Providers ("Agency Portal" and "Integrated Eligibility") - and this works fine through SoapUI

 

The STAGE env. has only one Auth. Provide "Agency Portal" which is our other name for Salesforce.


Both STAGE & TEST point to the same Auth URL - but different Consumer Key & Secret.

 

Other than that - I'm kind of in a loss until I troubleshoot more.

Outlaw
New Contributor

Re: OAuth get token can't open page

I had to fake a redirect uri and i have been up and running since that point, i am not sure why as my goal isnt to test the authentication component i was just glad i got a token.

 

http://localhost/callback

rlong98
Contributor

Re: OAuth get token can't open page

Yeah I already have that ... there has to be something up with the STAGE environment the way they have the OAuth setup

mojojojo
New Contributor

Re: OAuth get token can't open page

We have same issue here. The machine that is running SoapUI NG and the authorization server are on the same intranet. When clicking the get token button on SoapUI NG “Get Access Token from the authorization server” popup, the browser opens up with a "Unfortunately, we can't open this page!" message. The authorization server is accessible within the intranet using browsers like Chrome and Safari, but it is not accessible to connections from outside of the intranet.

 

We tried with Google OAuth using Implicit Grant flow where the authorization server is accessible from any network connections and everything worked fine. In our own test we use Authorization Code Grant flow. It is our speculation that the authorization server thinks the traffic is coming from an untrusted source (SoapUI NG) and thus blocked it.

 

The questions are:
1. Is this a bug in SoapUI NG? Note that both SoapUI NG machine and authorization server are on the same intranet, so they are able to connect with each other.
2. If it is not a bug, what might have caused this issue and? Is there a way to get around this? It doesn’t make much sense that to test a 3-legged OAuth in development requires the authorization server to be accessible from any network connections.

 

Thanks,

Mojo

mojojojo
New Contributor

Re: OAuth get token can't open page

The following worked for us to resolve this issue: 

 

Make sure you use Ready API and go to File > Preferences > Internal Browser > Check Trust the self-signed certificate.

 

Smiley Happy

 

Mojo

testhrishi
Frequent Contributor

Re: OAuth get token can't open page

Changing internal browser setting is not changing the behavior for me in this case. Still continue to get the error with implicit grant. what is the bets practice suggested in this case? or is this a bug?

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors