cancel
Showing results for 
Search instead for 
Did you mean: 

How do I turn off requests going to Google Analytics and fast.wistia.com in SoapUI NG?

SOLVED
kieron_horide-h
New Contributor

How do I turn off requests going to Google Analytics and fast.wistia.com in SoapUI NG?

While trying to trouble-shoot requests from SoapUI NG, I fired up Burp Suite and set the proxy in Ready! API to localhost:8080. In addition to my test's requests, the requests intercepted included ones to www.google-analytics.com and fast.wistia.com - every time I navigated around the SoapUI NG interface or ran a test.

 

This raised a bunch of questions in my mind: 

 

  1. Why are they there in the first place?
  2. Would this affect my SoapUI performance?
  3. Does this represent a potential privacy or security hole? Is my machine infected with something?
  4. While I can tell Burp Suite to ignore these, how can I turn them off?

Thanks in advance for any help.

 

Examples (note only Ready! API is set to use localhost:8080 proxy on this machine; I have closed the starter pages, only 1 test step open; fresh upgrade to version 1.4.0):

 

 

GET /embed/iframe_shim?domain=net HTTP/1.1
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Referer: http://smartbearsoftware.com/appindex/ready-starter-pages/pro/soapui-ng-starter-page.html
User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.44 (KHTML, like Gecko) JavaFX/8.0 Safari/537.44
Cache-Control: no-cache
Pragma: no-cache
Host: fast.wistia.com
Proxy-Connection: keep-alive
 
GET /Appindex/ready-starter-pages/pro/soapui-ng-starter-page.html HTTP/1.1
User-Agent: Java/1.8.0_45
Host: www.soapui.org
Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2
Proxy-Connection: keep-alive
 
GET /collect?<whole bunch of parameters>
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Referer: http://smartbearsoftware.com/appindex/ready-starter-pages/pro/soapui-ng-starter-page.html
User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.44 (KHTML, like Gecko) JavaFX/8.0 Safari/537.44
Cache-Control: no-cache
Pragma: no-cache
Host: www.google-analytics.com
Accept: text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2
Proxy-Connection: keep-alive

 

--
I use SoapUI NG Pro as part of Ready! API on Win7 
Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
AJaensson
Staff

Re: How do I turn off requests going to Google Analytics and fast.wistia.com in SoapUI NG?

Hi!

 

The calls to google analytics are anonymous usage statistics that we collect to be able to improve the product. It let's us see which features are used the most etc, so we know where to focus our resources.

 

When you first started Ready! API you got a pop-up asking whether you wanted to send these statistics or not. If you want to change this setting, you can go to Preferences->UI and look for "Disable usage statistics".

 

Regards,

Anders Jaensson

Ready! API developer

View solution in original post

3 REPLIES 3
AJaensson
Staff

Re: How do I turn off requests going to Google Analytics and fast.wistia.com in SoapUI NG?

Hi!

 

The calls to google analytics are anonymous usage statistics that we collect to be able to improve the product. It let's us see which features are used the most etc, so we know where to focus our resources.

 

When you first started Ready! API you got a pop-up asking whether you wanted to send these statistics or not. If you want to change this setting, you can go to Preferences->UI and look for "Disable usage statistics".

 

Regards,

Anders Jaensson

Ready! API developer

View solution in original post

deejmore
New Contributor

Re: How do I turn off requests going to Google Analytics and fast.wistia.com in SoapUI NG?

Hi,

 

I tried setting the property value -GcollectInfoForSupport=false when I call testrunner.bat, both from the command line and from Jenkins; However, the pop-up still comes up. How do I not see this pop-up? Will it go away if I use SoapUI pro, or is it the same?

 

By the way I am using Soap UI 5.2.0 on windows 2008 server. 

 

Thanks and best regards, 

 

DJ

tjdurden
Frequent Contributor

Re: How do I turn off requests going to Google Analytics and fast.wistia.com in SoapUI NG?

Trying adding the following property to your soapui-settings.xml file:

 

<con:setting id="UISettings@disable_analytics">false</con:setting>


Found this reply useful? Please endorse me on LinkedIn
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors