Ask a Question

Failed to start ReadyAPI error on launch

SOLVED
mar_szwi
New Contributor

Failed to start ReadyAPI error on launch

Hi!

I cannot launch ReadyAPI on one of my PCs. It crash when I click the icon in Start menu, the interface doesn't appear at all, just launch startup window.

OS: Windows 10 Enterprise ver. 1909

 

Works fine on Windows Server 2016

 

Log file attached.

 

Tried to find something here but there is nothing for Windows 10 and all post are a bit outdated so I decided to start a new post instead.

1 ACCEPTED SOLUTION

Accepted Solutions
ASviridov
Staff

Re: Failed to start ReadyAPI error on launch

Hi,

 

It seems that the issue is with your ReadyAPI settings.

 

Please open your "C:\Users\<UserName>\soapui-settings.xml" file in any text editor and set the right values for _HttpSettings@max_connections_per_host_ and _HttpSettings@max_total_connections_. The default values _500_ and _2000_ should work fine. These values cannot be 0, negative or too big.

 

Best regards,

Alexander Sviridov

ReadyAPI developer

View solution in original post

5 REPLIES 5
TanyaYatskovska
Community Manager

Re: Failed to start ReadyAPI error on launch

Hi @mar_szwi,

 

It's sad to hear this. Could you please try installing the latest ReadyAPI maintenance build? You can download it here:

https://support.smartbear.com/downloads/readyapi/maintenance/

 

Please uninstall the current product version, reboot the system and install the new version. Do you see an issue when starting ReadyAPI now?

 
---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
mar_szwi
New Contributor

Re: Failed to start ReadyAPI error on launch

Hi @TanyaYatskovska !

Thanks for replying to me! I already did that, with both 64 and 32 versions. I also tried to return to version 2.8.2 which I had previously and it worked previously, but results are the same...

I didn't reconfigure my PC lately, just installed a new web browser, do you think it may be relevant?

ASviridov
Staff

Re: Failed to start ReadyAPI error on launch

Hi,

 

It seems that the issue is with your ReadyAPI settings.

 

Please open your "C:\Users\<UserName>\soapui-settings.xml" file in any text editor and set the right values for _HttpSettings@max_connections_per_host_ and _HttpSettings@max_total_connections_. The default values _500_ and _2000_ should work fine. These values cannot be 0, negative or too big.

 

Best regards,

Alexander Sviridov

ReadyAPI developer

View solution in original post

mar_szwi
New Contributor

Re: Failed to start ReadyAPI error on launch

You nailed it @ASviridov! Thank you very much 🙂

ASviridov
Staff

Re: Failed to start ReadyAPI error on launch

@mar_szwi, you are welcome!

cancel
Showing results for 
Search instead for 
Did you mean: 

Join the Community

Ask Community Experts

Join more than 100,000 users worldwide. Ask questions, request features, post replies, award kudos, and more.

Join Now For Free

Already a member? Sign In