cancel
Showing results for 
Search instead for 
Did you mean: 

Disable Form Editor auto-insert

SOLVED
jakeyizle
New Contributor

Disable Form Editor auto-insert

I have loaded a WSDL to send SOAP requests, and the schema I am using has a list of objects, each with multiple fields. Because of how our data-driven testing is setup, for some of these objects we store the entire section of XML in one single property (versus one xml field = one property)

 

<ObjectList>
    <Object1>

        <someField1>$Property1</someField1>

        <someField2>$Property2</someField2>

   </Object1>

    <Object2>$Object2Property</Object2>

</ObjectList>

 

If I accidentally leave the Form Editor open and start my tests, it "helpfully" adds required fields:

<Object2>$Object2Property<someField1/><someField2/></Object2>

 

Which causes a WSDL validation error because those fields are duplicated (someField1 and someField2 and already included in $Object2Property).

 

Is there anyway to disable this behavior? It's not a critical issue or anything, it's just super annoying because I do use the Form Editor on occasion but I jsut forget to switch to a different Request Editor window before starting a bunch of tests, and this causes failures. And I need to re-edit the XML to remove these extra fields that have been added in.

 

I have "Remove Empty Content" set to true but that has not helped.

1 ACCEPTED SOLUTION

Accepted Solutions
sonya_m
Community Manager

Re: Disable Form Editor auto-insert

@jakeyizle I talked to the devs and it seems like this is the expected behavior of the tool at the moment. I would suggest creating a feature request here.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

2 REPLIES 2
sonya_m
Community Manager

Re: Disable Form Editor auto-insert

Thank you for the question!

 

Anyone is facing this/ knows ways to avoid this? Your help is appreciated as always🙂

@HimanshuTayal @PrathapR @msiadak @aaronpliu 

 


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
sonya_m
Community Manager

Re: Disable Form Editor auto-insert

@jakeyizle I talked to the devs and it seems like this is the expected behavior of the tool at the moment. I would suggest creating a feature request here.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors