Forum Discussion

gos2610's avatar
gos2610
New Contributor
7 months ago

JDK 17 Support for SoapUI

Hello dear Smartbear-Team,
is there currently a planning when SoapUI will support JDK 17? If I see it correctly, this has already been done for ReadyAPI.

Do you have a release date for an new SoapUI version supporting JDK 17?

Thanks
Stefan

5 Replies

  • JOHNSMITH167's avatar
    JOHNSMITH167
    Occasional Contributor

    As of my last update in January 2022, I don't have real-time data. To find out SoapUI's support for JDK 17, visit Smartbear's official website or contact their support. Check release notes for updates. For the latest information, consult official channels.# API Flange

  • gos2610's avatar
    gos2610
    New Contributor

    We are using the SoapUI for generating a wsmocks.war named WAR-File and install this file into an JDK 17 based Wildfly/JBoss. So in this case we don't use the internal JDK, but we need to generate a JDK 17 ready WAR-File.

    The generated WAR-File expecting a javax servlet-Class. So in JBoss 8 or Wildfly 29 there is just a jakarta lib included.

    {"WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"WFLYCTL0080: Failed services" => {"jboss.deployment.unit.\"wsmocks.war\".undertow-deployment.UndertowDeploymentInfoService" => "Failed to start service
        Caused by: java.lang.NoClassDefFoundError: Failed to link com/eviware/soapui/mockaswar/MockAsWarServlet (Module \"deployment.wsmocks.war\" from Service Module Loader): javax/servlet/http/HttpServlet"}}}}

    • Carsten_Zimmer's avatar
      Carsten_Zimmer
      New Contributor

      As an addition to the response of gos2610:

      We downloaded and installed are 14days-free-tial-license of ReadyAPI and tried to build our war-file with this version.
      And at the end we got the same error. So the ReadyAPI (which should support Java 17) generated a war-file, which still uses libraries (javax.servlet), which are not supported by a Java17-environment.
      I'm quiet disappointed that the wargenerator.bat was not changed in a way that its created war uses the jakarta-jars, which are expected for a Java17-environment

  • nmrao's avatar
    nmrao
    Champion Level 3

    Doe it throw any error when JDK17 is used instead of internal jdk?

    • timaharrison's avatar
      timaharrison
      Occasional Contributor

      I appear to get issues with the running of groovy steps when JDK17 is used - extract from the error log is shown below. [my installation points at the machine JDK instance and we have had to remove the embedded JRE because of corporate compliance issues]

      Looking at the system requirements for SoapUI 5.7.2, Java 16 is listed.  What I'd like to know is

       -when the next version is due,

      and whether support for Java 17 is planned

      Thanks

       

      • Wed Jun 19 11:23:10 BST 2024:ERROR:BUG! exception in phase 'semantic analysis' in source unit 'Script1.groovy' Unsupported class file major version 61
      • BUG! exception in phase 'semantic analysis' in source unit 'Script1.groovy' Unsupported class file major version 61