Forum Discussion

Coder's avatar
Occasional Contributor
4 years ago

Error Response return null while fetching more than 50,000 records over SOAPUI

Hi All,

i tried to fetch around 300 records and it gets working but when i tried to fetch more than 50,000 records, an error occurred "Response return null"

Please provide me some support in case someone gets stuck with it.


12 Replies

  • Coder : what response code you are getting, could you please check in raw response and share here?

    • richie's avatar
      Community Hero
      Hi Coder,

      It's likely youre soapui instance is running out of available resource (RAM/cpu) if you say fetching 300 records is fine, but the error response occurs when you try retrieving a result with 50000 records in it.
      You might want to try optimising your laptops performance settings (setting for "best performance", stopping anything extra you dont need starting at bootup, altering you VM/swapfile settings, etc.) as well as altering soapuis memory management via the vmoptions.

      Please see the following link


      • Coder's avatar
        Occasional Contributor
        Hi richie,
        I will change the memory size of the file and I will feed u back the result but are you certain that the response return null is because of the insufficient memory?